Feathery - Email sending degraded – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Email sending degraded
Resolved
Degraded performance
Started 19 days ago
Lasted about 1 hour
Affected
Forms
Operational from 1:40 PM to 2:45 PM
Updates
Resolved
April 13, 2025 at 2:45 PM
Resolved
April 13, 2025 at 2:45 PM
This incident has been resolved.
Investigating
April 13, 2025 at 1:40 PM
Investigating
April 13, 2025 at 1:40 PM
We are currently investigating this incident.