Feathery - Form Outage – Incident details

Form Outage

Resolved
Partial outage
Started 8 days agoLasted about 1 hour

Affected

Dashboard

Operational from 2:00 PM to 3:00 PM

Forms

Major outage from 2:00 PM to 3:00 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Forms are taking a long time to load or are failing to load. We are currently investigating this incident.